Difference between pages "Laserleikkuri" and "3D-tulostin"

From Tampere Hacklab Wiki
(Difference between pages)
Jump to: navigation, search
 
 
Line 1: Line 1:
 
[[Category:Työkalut]]
 
[[Category:Työkalut]]
[[File:laserleikkuri.jpeg|right|thumb|upright|400px||[[Laserleikkuri]]]]
 
= Kuvaus =
 
[[Media:laserleikkuri.jpeg|Yilong Ping Pong -laserleikkuri]]
 
  
* Leikkuuala 1300*900 mm
+
[[File:ultimakerv1.jpeg|right|thumb|upright|400px||[[Ultimaker V1 3D-tulostin]]]]
 +
Hacklabilla majailee kiinteästi [[Media:ultimakerv1.jpeg|Ultimaker 3D-tulostin]], joka on yhdistyksen omistama.
  
== Materiaalit ==
+
= Mallinnus =
* Laseroitavaksi vaneriksi sopii tällä tietoa vain urealiimattu (ureaformaldehydipohjainen liima) vaneri (EN 314-2, luokka 1, interior; esim. UPM Wisa Interior). Fenolihartsiliimaista vaneria laser ei pysty leikkaamaan, säde ei pääse liiman läpi ja lähinnä polttaa rumaa jälkeä.
+
Mallinnukseen kelpaa periaatteessa mikä tahansa ohjelma joka osaa tuottaa STL-tiedostoja. Käytännössä kelpaa mikä tahansa 3D-mallinnukseen sopiva ohjelma, tai 3D-CAD. Jos et ole käyttänyt vastaavia ohjelmia aiemmin niin alkuun (ja varsin pitkällekkin) pääsee Trimble Sketchupilla.
* Muoveista akryyli.
+
* TODO: lisää laserin viereiseen seinään liimattu kaavio/tiedot siitä
+
  
=Laserleikkurin käynnistys=
+
*Trimble SketchUp (Windows/Mac/Linux (wine)): http://www.sketchup.com/
#Käynnistä [[paineilma]] ohjeiden mukaan (tai varmista että paineilma on päällä)
+
**STL plugin SketchUp:iin: http://www.guitar-list.com/download-software/convert-sketchup-skp-files-dxf-or-stl
#[[Media:Laser1.jpg|Varmista, että laserleikkuri on ''sammutettu'' laitteen oikeassa kyljessä sijaitsevasta punaisesta napista]]
+
*Blender 3D (Windows/Mac/Linux): http://blender.org/
#[[Media:Laser2.jpg|Laita päävirta päälle seinässä olevasta kytkimestä (''valkoinen "Laser ja imuri" -katkaisija'')]]
+
*FreeCad
##[[Media:Laser3.jpg|Varmista että plasmakopin päällä oleva puhallin menee päälle]]
+
*OpenSCAD
##Varmista, että imukaapin oikeassa reunassa oleva läppä on kiinni, muuten imuteho puolittuu koska sama puhallin käytössä.
+
** MCAD-lisäkirjasto joidenkin mallien tulostukseen:
#[[Media:Laser4.jpg|Laita molempiin näyttöihin virta]]
+
<nowiki>
#Käynnistä ohjaustietokone
+
cd OPENSCADIN KIRJASTOT
#Odota että tietokone käynnistyy, kirjaudu sisään tietokoneeseen (laser/laser)
+
esim cd /usr/share/openscad;
##Avaa tietokoneen työpöydällä oleva Launch laser -ohjelma
+
mkdir libraries
##Käynnistä laserleikkuri oikean kyljen punaisesta virtakytkimestä
+
cd libraries
#Varmista, ettei leikkuualustalla ole mitään mikä estää laserleikkurin akseleiden liikkeen
+
git clone https://github.com/SolidCode/MCAD.git
#Paina LinuxCNC-ohjelmasta Emergency Stop pois päältä
+
</nowiki>
#Paina Machine Power päälle
+
#Paina Home All -nappia
+
#Varmista että X- ja Y-akseleiden viereen syttyy Home-merkki
+
#Laite on nyt käyttövalmis
+
  
Opastusvideo by Arno: https://www.youtube.com/watch?v=KpANlaGfnkc
+
MCAD kirjasto on käytössä koodissasi include MCAD/jotain.scad
  
= Polttopisteen säätö =
 
2016/08: Polttopistettä ei tarvitse enää säätää (ainakaan yleisimmille materiaaleille: akryylille ja 6 mm vanerille). Tämä siis lähinnä sivistykseksi:
 
  
Polttopiste pyritään samaan keskelle leikattavaa materiaalia, esim. 6 millin vanerilla 3 millin syvyyteen. Ohuilla materiaaleilla (esim. 3 mm akryyli) polttopisteen voi jättää materiaalin pintaan.
+
Kappaleen suunnittelussa on hyvä pitää mielessä 3D-tulostiemen rajoitteet: tyhjän päälle ei voi tulostaa (ilman kikkailua). Pidä siis huoli että kappaleessa ei ole paria senttiä pitempiä siltoja, eikä kappaleen seinämä leviä liian nopeasti ulospäin.
  
Laserin kannen päällä on pieniä t-kirjaimen mallisia paloja, jotka sopivat laserin "tukien" väliin. Laita oikean kokoinen pala paikoilleen, avaa linssin siipimutteri ja kiristä palan päälle.
+
'''Älä käytä missään vaiheessa mallien nimissä skandeja''' (ainakin replicatorG hämääntyy ääkkösistä)
  
= Leikkuuteho ja nopeus =
+
==== Mittatarkka mallinnus ====
Linssin puhtaus vaikuttaa tehoon huomattavasti, <s>putsaa siis linssi aina kuin aloitat leikkuun.</s> Jos epäilet linssin olevan likainen, ilmoita Arnolle. Linssin väärä käsittely tuhoaa linssin pinnoitteen.<br>
+
Jos haluat tehdä edes jollain tapaa mittatarkkaa, tee malliin seuraavat muutokset:
Mielummin pienemmällä teholla, säästää laserputkea ja peilejä!<br>
+
Jos layerin nimestä puuttuu arvot, käytetään oletusarvoja 10 % ja 300 mm/min.
+
  
3 mm akryylin leikkaus: teho 50, feed 500.<br>
+
'''Arvot ovat ohjeellisia ja voivat muuttua eri tulostusparametreilla. Nämä ovat Curan oletusarvoilla. Jos teet mittauksia, saa tätä sivua päivittää. Eri muoveilla saattaa olla myös vaikutusta.'''
Akryylin kaiverrus: teho 2-5, feed esim. 500.
+
  
6 mm vanerin leikkaus: power 50, feed 350-400.<br>
+
* Reiät
Vanerille feed 400 & teho 2 tekee haamujälkeä, joka erottuu juuri ja juuri jos katsoo oikein tarkasti. <br>
+
** AnDe: Lisää 0.4 mm reiän halkaisijaan (curan oletuksista poikkeavat parametrit: Wall thickness 0.4 mm, bottom/top thickness 0.4 mm, fill density 50 %, printing temperature 200)
Vanerille feedeillä 400-700 teho 3 tuottaa vaalean, näkyvän ja luettavan jäljen. <br>
+
** Cos: Lisää 0.22 mm reiän halkaisijaan
Vanerille kaiverruksen yleisarvoksi sopii siis teho 5-7, feed 400-700. Alla olevista kuvista ja testaamalla voi etsiä itselle mieluisinta jälkeä jos halajaa hienosäätää.<br><br>
+
* Akselit
 +
** Cos: Lisää 0.2 mm akselin halkaisijaan
  
Feed 700 tekee vielä pääasiassa suoria kulmia (silmämääräisesti arvioituna).<br>
+
=== Tulostus ===
Feed 1000 (teho 10) pyöristää teräviäkin kulmia hieman. Sopivassa kulmassa olevat viivat kaivertuvat siksakkina.<br>
+
Tulostus onnistuu parhaiten Cura-ohjelmistolla. Se on valmiiksi asennettuna tulostusläppäriin ja defaulttiasetuksilla tulostuksen pitäisi toimia ihan ok.
Feed 2000 (teho 10) pyöristää kulmia jo selkeästi. Lisäksi jos viiva on sopivassa kulmassa, se kaivertuu hienon hienona siksakkina viivan sijaan, ja kaiken suuntaisissa viivoissa kaiverrusjälki on pistemäistä tasaisen viivan sijaan.  
+
  
[[File:Tre-hacklab-laser-feed-nopeuksia-201608.jpg]]
+
'''HUOM, älä nosta lämpötilaa koskaan yli 215 c. Kovat lämmöt polttavat muovin suuttimeen kiinni.'''
  
= Mittatarkkuus =
+
*Käynnistä tulostusläppärillä Cura-softa
- Lasersäteen paksuus noin 0.1 mm (kerf).<br>
+
*Käynnistä Ultimaker virtakytkimestään
- Jos teet reiän, tee siitä 0.05 mm pienempi kuin haluat<br>
+
*Avaa haluttu STL-tiedosto Curaan painamalla "Load Model"
- Tee kappaleista 0.05 mm suurempia kuin haluat<br>
+
**Tarkasta, että malli näyttää järkevältä ja on oikein päin. Jos ei, sitä voi vielä korjailla Curalla.
 +
*Avaa tulostusikkuna painamalla "Print model"
 +
*Varmista että tulostusalusta on teipattu ja puhdas
 +
**Varmista myös että tulostusalusta on tukevasti kiinni eikä liiku erityisemmin jos yrittää esim. nostaa. Jos ei, paina alustaa alaspäin ja liikuta oikealle (Ultimaker-logoon päin katsottuna)
 +
**Tulostuspäätä ja -alustaa voi liikutlla Jog-välilehdellä
 +
***Tulostuspään/alustan ajelunäkymän saa Cura 14:ssa esille painamalla "Print". Jos siellä ei ole, varmista että File -> Preferences -> Printing window type on Prointerface UI.
 +
*Varmista että muovirulla on paikallaan ja vapaa pyörimään
 +
*Paina "Print"
 +
**Tulostus alkaa lämpötilan noustua tulostuslämpöön
 +
**Lämpöikkunassa näkyy käyrä lämpötilasta
 +
**Jos lämpö ei tahdo nousta olet unohtanut käynnistää tulostimen katkaisijasta
 +
**Huomaa myös että pelkkä printtausikkunan avaaminen Curassa ei riitä vaikka se noin muuten yhdistääkin printteriin, lämpötilan nosto vaatii Print-napin painamista (vaihtoehtoisesti jos haluaa ajaa käsin Prointerfacella niin asianmukaiseen kenttään syöttäminen)
  
= Mallin luominen Inkscapella =
+
Lisää ohjeita: http://wiki.ultimaker.com/Cura
Inkscape-kurssimateriaali: https://raw.githubusercontent.com/vranki/course_materials/master/inkscape-kurssi/inkscape-kurssi_remark.html (talleta tiedostoon ja avaa selaimessa).
+
  
 
+
[[Luokka:Projektit]]
* Piirrä mitä piirrät. Piirtoa helpottaa jos vaihdat mittayksikön millimetreiksi (Document Preferences>Default unit: mm). Origo on sivun vasemmassa alakulmassa. Valitse kaikki (Edit > Select all on all layers), poista groupit (Group > Ungroup), tee kaikesta polkuja (Edit > Select all on all layers; Path > Object to path; ''tärkeää'').
+
* Kaiken leikattavan tulee olla tasolla. Avaa Layers-paletti, lisää uusi taso jos dokumentissa ei vielä ole tasoja. Valitse kaikki leikattavat polut, sitten valitse Layers-valikosta "Move Selection to Layer.."
+
* Nimeä taso: "leikkausteho% [feed=nopeus]", esimerkiksi "50 [feed=400]". Ei lainausmerkkejä.
+
** Uusi Export-plugin ymmärtää myös muita nimeämistapoja, joten tasoja voi nimetä kuvaavammin. Katso lisää exportin helpistä.
+
* Layerit leikataan järjestyksessä: ylin ensin.
+
 
+
* Valitse kaikki leikattavat polut (esim. Select All on All Layers)
+
* Extensions > Export > TurnkeyLaser Exporter
+
** Exportterin asetukset
+
*** Advanced
+
**** Mainboard: LinuxCNC
+
**** [ ] are you using pronterface
+
*** Preferences
+
**** Y axis origin: Bottom Left
+
**** File name: tiedosto.ngc
+
**** [ ] Home X and Y before
+
**** [x] Home X and Y after
+
**** [x] Air assist (paineilmapuhallus)
+
** Kun asetukset on kunnossa, paina Apply
+
* .ngc-tiedosto ilmestyy antamaasi hakemistolle (Desktopille jos tyhjä). Kiikuta se laserille esim. verkkolevyä (lasertemp-kansioon) pitkin tai muistitikulla.
+
 
+
== G-koodi-plugin ==
+
 
+
* Labin koneille on asennettu Inkscape-plugin (Turnkey Laser Exporter) jolla g-koodi luodaan. G-koodin generointiplugin: https://github.com/vranki/laser-gcode-exporter-inkscape-plugin
+
* Modattu versio by cos
+
* HUOM: Windowsissa PIL-kirjastoa ei tarvitse päivittää. Sitä tarvitaan vain rasterikuvien leikkauksessa (nykyinen systeemi ei tue rasterikuvia). Riittää, että asennat .inx ja .py-tiedostot Inkscapen extensions-hakemistoon.
+
* Saa parannella!
+
 
+
= Laserin ohjauskone =
+
Käytössä LinuxCNC.
+
Paineilman voi tilapäisesti laittaa pois päältä ja takaisin päälle painamalla F7:aa.
+
Jos leikkuun haluu aloittaa muualta kuin tiedoston alusta, etsi haluamasi rivi, klikkaa hiiren oikealla ja valitse "Run from here". Jos Run from here on harmaa, paina LinuxCNC:n yläpalkista stoppia.
+
 
+
== G-koodin erikoisuuksia ==
+
* Koodin alussa oltava M7 ; Enable air
+
* Koodin lopussa oltava M2 ; Program end
+
* Rasterikuvat (G7) ei toimi alkuunkaan. Keksiikö joku miten niitä saisi tehtyä?
+
 
+
== G-Koodin alustuskomennot ==
+
*G21 (Programming in millimeters)
+
*G90 (Absolute programming)
+
*G17 (XY plane selection)
+
*M05 (Spindle stop, laser pois päältä)
+
 
+
= Prosessin kehitysideoita =
+
Näitä voisi kokeilla
+
* LaserWeb (laserin päähän tuleva web-pohjanen ohjaustyökalu) https://github.com/openhardwarecoza/LaserWeb
+
 
+
= Vinkkejä =
+
- Tsekkaa Thingiversestä valmiita laseroitavia esineitä http://www.thingiverse.com/tag:laser <br>
+
- Tabbed Box Generatoreilla pystyy tekemään omilla mitoilla sormiliitoksilla kasattavai laatikoita. Löytyy esim Inkscape-extensionina ja selainpohjaisena. <br>
+
- Isot leikkaukset kannattaa kokeilla esim. aaltopahville kalliin materiaalin tuhlauksen sijaan.<br>
+
- Image 2 Gcode converter: http://www.thingiverse.com/thing:770081
+

Revision as of 09:22, 28 September 2016

Hacklabilla majailee kiinteästi Ultimaker 3D-tulostin, joka on yhdistyksen omistama.

Mallinnus

Mallinnukseen kelpaa periaatteessa mikä tahansa ohjelma joka osaa tuottaa STL-tiedostoja. Käytännössä kelpaa mikä tahansa 3D-mallinnukseen sopiva ohjelma, tai 3D-CAD. Jos et ole käyttänyt vastaavia ohjelmia aiemmin niin alkuun (ja varsin pitkällekkin) pääsee Trimble Sketchupilla.

cd OPENSCADIN KIRJASTOT 
esim cd /usr/share/openscad;
mkdir libraries
cd libraries
git clone https://github.com/SolidCode/MCAD.git
 

MCAD kirjasto on käytössä koodissasi include MCAD/jotain.scad


Kappaleen suunnittelussa on hyvä pitää mielessä 3D-tulostiemen rajoitteet: tyhjän päälle ei voi tulostaa (ilman kikkailua). Pidä siis huoli että kappaleessa ei ole paria senttiä pitempiä siltoja, eikä kappaleen seinämä leviä liian nopeasti ulospäin.

Älä käytä missään vaiheessa mallien nimissä skandeja (ainakin replicatorG hämääntyy ääkkösistä)

Mittatarkka mallinnus

Jos haluat tehdä edes jollain tapaa mittatarkkaa, tee malliin seuraavat muutokset:

Arvot ovat ohjeellisia ja voivat muuttua eri tulostusparametreilla. Nämä ovat Curan oletusarvoilla. Jos teet mittauksia, saa tätä sivua päivittää. Eri muoveilla saattaa olla myös vaikutusta.

  • Reiät
    • AnDe: Lisää 0.4 mm reiän halkaisijaan (curan oletuksista poikkeavat parametrit: Wall thickness 0.4 mm, bottom/top thickness 0.4 mm, fill density 50 %, printing temperature 200)
    • Cos: Lisää 0.22 mm reiän halkaisijaan
  • Akselit
    • Cos: Lisää 0.2 mm akselin halkaisijaan

Tulostus

Tulostus onnistuu parhaiten Cura-ohjelmistolla. Se on valmiiksi asennettuna tulostusläppäriin ja defaulttiasetuksilla tulostuksen pitäisi toimia ihan ok.

HUOM, älä nosta lämpötilaa koskaan yli 215 c. Kovat lämmöt polttavat muovin suuttimeen kiinni.

  • Käynnistä tulostusläppärillä Cura-softa
  • Käynnistä Ultimaker virtakytkimestään
  • Avaa haluttu STL-tiedosto Curaan painamalla "Load Model"
    • Tarkasta, että malli näyttää järkevältä ja on oikein päin. Jos ei, sitä voi vielä korjailla Curalla.
  • Avaa tulostusikkuna painamalla "Print model"
  • Varmista että tulostusalusta on teipattu ja puhdas
    • Varmista myös että tulostusalusta on tukevasti kiinni eikä liiku erityisemmin jos yrittää esim. nostaa. Jos ei, paina alustaa alaspäin ja liikuta oikealle (Ultimaker-logoon päin katsottuna)
    • Tulostuspäätä ja -alustaa voi liikutlla Jog-välilehdellä
      • Tulostuspään/alustan ajelunäkymän saa Cura 14:ssa esille painamalla "Print". Jos siellä ei ole, varmista että File -> Preferences -> Printing window type on Prointerface UI.
  • Varmista että muovirulla on paikallaan ja vapaa pyörimään
  • Paina "Print"
    • Tulostus alkaa lämpötilan noustua tulostuslämpöön
    • Lämpöikkunassa näkyy käyrä lämpötilasta
    • Jos lämpö ei tahdo nousta olet unohtanut käynnistää tulostimen katkaisijasta
    • Huomaa myös että pelkkä printtausikkunan avaaminen Curassa ei riitä vaikka se noin muuten yhdistääkin printteriin, lämpötilan nosto vaatii Print-napin painamista (vaihtoehtoisesti jos haluaa ajaa käsin Prointerfacella niin asianmukaiseen kenttään syöttäminen)

Lisää ohjeita: http://wiki.ultimaker.com/Cura

Luokka:Projektit